You may encounter the error "txn version not supported" when trying to send DOT or KSM from your Ledger via the Polkadot-JS UI or Ledger Live. 


This error is caused by outdated software. To fix this,


  • Makes sure your Ledger's firmware is updated
  • Update your Ledger Live app to the latest version
  • Update your Polkadot or Kusama app to the latest version - depending on which network you are experiencing this error.


These steps didn't solve the issue


If the problem persists after these steps, then it's possible a runtime upgrade has recently happened on the chain. Polkadot and Kusama can upgrade themselves with a governance decision, but these upgrades sometimes change the way transactions are constructed in a way that is incompatible with previous versions. When this happens a new version of the Polkadot or Kusama Ledger app needs to be released.


This usually happens pretty quickly after the runtime upgrade, but until this new version is developed and added to Ledger Live, you will be receiving this error when trying to sign transactions on you Ledger.


Please let us know below if you found this article helpful or email us at Support if we can be of further assistance.